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Landing Pages



Landing Page Home 

Page Overview

● Landing page home page allows you to see a full 
list of all created landing pages, their publish status, 
and other information

● Can use a variety of views and filters to find 
specific landing pages based on certain criteria

● Can jump into editing a landing page by clicking the 
name of the landing page, or hover over it and click 
“Details” to see more in-depth information on the 
landing page

● To access this page, go to “Content” > “Landing 
Pages”
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Creating a Landing Page
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1. On the main landing page home page, click the orange 
“Create” button near the top right of the page and click 
“Landing Page”

2. Name your landing page and select the correct sub-
domain

3. Select the template you’d like to use for your landing 
page. You can use either a theme template or (if 
available) a custom template created by a developer



Editing a Landing Page - Modules
● To add modules to a page, click the “+” icon near 

the top left of the editor and drag the module you’d 
like to add onto the page

● To delete a module on the page, hover over said 
module and click the trash can icon that appears to 
delete the module

● Click a module within the landing page editor to edit 
the module via the editing tool on the left side of the 
page. You can also click the pencil icon that 
appears when you hover over the module to edit it

● To clone a module, hover over it and click the two-
card icon that appears to clone the module

● To move a module to a different location on the 
page, click and hold the module and then drag it to 
where you’d like it to be moved
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Editing a Landing Page -

Sections
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● To add sections to a page, click the “+” icon near the 
top left of the editor, select the “Sections” tab, and drag 
the section you’d like to add onto the page

● To delete a section on the page, hover over said 
section and click the trash can icon that appears to 
delete the section

● Click a section within the landing page editor to edit the 
section via the editing tool on the left side of the page. 
You can also click the pencil icon that appears when 
you hover over the section to edit it

● To clone a section, hover over it and click the two-card 
icon that appears to clone the section

● To move a section to a different location on the page, 
click and hold the section and then drag it to where 
you’d like it to be moved

● To save a custom section you created in the editor, 
hover over the section, click the dropdown arrow icon, 
and click “Save section”



Editing a Landing 

Page - Layouts

● To add a layout to a page, click the “+” icon near 
the top left of the editor, select the “Layouts” tab, 
and drag the layout you’d like to add onto the page

● Once a layout has been placed, you can then add 
the desired modules to it

● To move a layout to a different location on the 
page, click and hold the layout and then drag it to 
where you’d like it to be moved

● To save this new layout as a custom section, hover 
over the section, click the dropdown arrow icon, 
and click “Save section”
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Editing a Landing Page -

Settings (Part 1)
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● Use the “File” tab to:
○ Quickly create a new page
○ Run an A/B test of the current page
○ Run an adaptive test of the current page
○ Create a multi-language variant of the page
○ Use AI Translate to translate the page to a new 

language
○ Clone the page
○ Delete the page

● Use the “Edit” tab to:
○ Undo a change
○ Redo a change
○ Update the theme of a page

● Use the “View” tab to:
○ View the version history of the page
○ Quick access to page details
○ Preview the page on a new tab



Editing a Landing Page -

Settings (Part 2)
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● Use the “Settings” tab to:
○ Update the general settings of the page, such 

as URL, title tag, meta description, and more
○ Set a featured image for the page
○ View and/or update the template of the page
○ Set the language of the page
○ Set whether the page should be password 

protected or be accessible to specific site 
visitors

○ Input custom header and footer code onto the 
page

● Use the “Help” tab to:
○ Gain access to a walkthrough of the landing 

page editor
○ Access HubSpot’s Knowledge Base for building 

a website



Previewing Your 

Landing Page

● To preview how your page will look on different 
devices, click the “Preview” button near the top 
right of the editor page

● If using personalization tokens or smart rules, you 
can preview how the page will look for that specific 
contact via the “Preview as” settings near the top 
left of the preview tool

● You can open a new tab to view the page by 
clicking the “ Open in a new tab” link near the top 
right of the preview page

● You can copy a preview link of the page to send to 
coworkers via the “Copy link” button near the top 
right of the preview page
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Publishing Your Landing Page
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● To publish your landing page instantly, click the orange 
“Publish” button near the top right of the page editor

● To set a specific time for the landing page to either 
publish or unpublish, click the dropdown arrow next to 
the orange “Publish” button near the top right of the 
page editor and click “Publishing options”

● Choose the specific time and date that you’d like to 
have your landing page published/unpublished, and 
then click “Schedule”

○ You can schedule when the landing page is 
published and is unpublished at the same time 
if needed



Forms



Forms Page Overview

● The forms page allows you to view all forms 
created within HubSpot, their publish status, and 
see a quick view of how they are performing

● Allows you to create custom views that segment 
the forms based on certain criteria

● Four different type of HubSpot forms:
○ Non-HubSpot forms
○ Regular forms
○ Pop-up forms
○ Blog comment forms

● To access this page, go to “Marketing” > “Forms”
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Creating a New Form
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● To create a new form, click the orange “Create new 
form” button near the top right corner of the forms page

● Select the type of form you’d like to create. The forms 
you can currently create include:

○ Embedded form
○ Standalone page
○ Pop-up box
○ Dropdown banner
○ Slide in left box
○ Slide in right box



Selecting a Form 

Template

● There are a variety of templates to choose from 
when creating a new form, which include:

○ Blank template
○ Payment form
○ Registration form
○ Contact us form
○ Newsletter sign-up form
○ Support form
○ eBook download form
○ Event registration form

● All of these templates can be further updated once 
you’re in the form editing tool
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Editing Your Form (Part 1)
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● To add fields to your form, use the search bar on the 
left side to search for the field you’d like to add. Once 
found, click and drag the field to where you’d like to 
place it on the form

● To delete a field from your form, hover over the field 
and then click the trash can icon to delete the field

● To mark a field as either required or optional, hover 
over the field and click the drop down arrow, and then 
select “Mark as required/”Mark as optional”



Editing Your Form (Part 2)

● To access more settings for your form fields, click 
the field in the form builder to have the field settings 
tool appear on the left side of the page.

● Within the field settings tool you can:
○ Make the field required/optional
○ Make the field hidden
○ Change the label of the field
○ Add help text to the field
○ Add placeholder text to the field
○ Set a default value for the field

● You can also add logic-based criteria via the 
“Logic” tab to auto-populate additional fields if 
another field has a specific value
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Editing Your Form 

Settings

19

● To edit the form settings, click the “Options” tab near 
the top of the form editor

● Within the “Options” settings you can:
○ Choose what happens after someone submits 

the form (i.e. redirect to new page, show a 
thank you message, etc.)

○ Set the lifecycle stage of the contact after form 
submission

○ Send submission notification email to contact’s 
owner/specific HubSpot users

○ Edit form/error message language
○ Setting to always create a contact record for 

new email addresses
○ Setting to add a link to reset the form
○ Setting to pre-populate fields with known 

values



Editing Style of Your Form

● To edit the style of your form, click the “Style and 
preview” tab near the top of the form editor

● Here you are able to:
○ Edit the font and styles of the form
○ Edit the colors of the form (i.e. label colors, 

button colors, etc.)
○ Preview the form as a specific contact
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Setting Up Form Automations
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● To set up simple automations for your form, click the 
“Automation” tab near the top of the form editor

● Here you can quickly create an automation that sends 
out an email to the contact after they submit the form

● If however you need to have a more complex 
automation created for this workflow, we recommend 
skipping this step and instead create the automation 
via HubSpot’s workflows tool



Publishing Your Form

● To publish your form, click the orange “Update” 
button near the top right of the form editor, then 
click the “Publish” button that appears on the pop 
up page

● You’ll then be given the options to either share a 
link to the form via a URL, or copy the embed code 
of the form to be implemented onto a page (such as 
a non-HubSpot page)

● You can now implement the form on any HubSpot 
web pages or landing pages via the “Form” module
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Calls to Action (CTAs)



CTAs Page Overview
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● The CTAs page overview allows you to see all CTAs 
currently created, their publish status, and a quick stats 
overview (i.e. “Views”, “Clicks”, etc.)

● You can create custom view and add filters to see 
specific forms

● The “Analyze” tab at the top allows you to see an 
overview of how well your CTAs are performing

● To access this page, go to “Marketing” > “CTAs”



Creating a CTA

● To create a new CTA, click the orange “Create” 
button near the top right of the CTAs page

● You will then have the option to choose a HubSpot 
template you’d like to use for your CTA, or to create 
your CTA from scratch

● Choose the right type of CTA you’d wish to create 
based off where you will be implementing it and it’s 
overall function (i.e. landing page, email, etc.)
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Building Your CTA
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● Once in the CTA builder, you’ll have the ability to edit 
specific content of your CTAS based off the type of 
CTA you’ve chosen

○ This content can include CTA copy, button 
color, link URL, etc.

● You will also have access to edit the style of your CTA, 
such as the text font, button colors, background, and 
more

● A preview of how your CTA will look like can be seen 
on the right side of the CTA editor, and will update 
automatically as changes are made

● You can also preview your CTA via the “Preview” 
button near the top right corner of the CTA builder



CTA Options

● You can update the options of your CTA via the 
“Options” tab near the top of the CTA editor

● Within the “Options” tab, you’ll be able to assign the 
CTA to a specific HubSpot campaign as well 
choose whether to track clicks through a redirect or 
through the browser:

○ Track clicks through redirect: Track clicks 
to your CTA by directing visitors to an initial 
URL, which associates the click with the 
CTA, before redirecting them to the final 
page.

○ Track clicks through the browser: 
Tracking through the browser will allow the 
use of anchor links and will not re-write links 
to use a redirect.
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Publishing Your CTA
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● Once you’ve finished creating your CTA, click the 
orange “Review and publish” button near the top right 
of the page

● Confirm that all CTA details and settings are correct, 
and if so click the orange “Publish now” button

● You’ll then have the ability to use this CTA within 
HubSpot-created content such as landing pages and 
emails, as well as on non-HubSpot pages via an 
embed code that appears after publishing



Additional HubSpot Resources
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● Create and customize pages

● Create forms

● Create calls-to-action (CTAs)

https://knowledge.hubspot.com/website-pages/create-and-customize-pages
https://knowledge.hubspot.com/forms/create-forms
https://knowledge.hubspot.com/ctas/create-calls-to-action


Thank you
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